Change the look of Adwaita, with ease
Go to file
David Lapshin 3abe611a9d
build(deps): bump peter-evans/create-pull-request from 6.0.2 to 6.0.5 (#889)
Bumps
[peter-evans/create-pull-request](https://github.com/peter-evans/create-pull-request)
from 6.0.2 to 6.0.5.
<details>
<summary>Release notes</summary>
<p><em>Sourced from <a
href="https://github.com/peter-evans/create-pull-request/releases">peter-evans/create-pull-request's
releases</a>.</em></p>
<blockquote>
<h2>Create Pull Request v6.0.5</h2>
<p>⚙️ Fixes an issue with proxy support for users that run self-hosted
behind a proxy.</p>
<h2>What's Changed</h2>
<ul>
<li>fix: update proxy support to follow octokit change to fetch api by
<a href="https://github.com/peter-evans"><code>@​peter-evans</code></a>
in <a
href="https://redirect.github.com/peter-evans/create-pull-request/pull/2867">peter-evans/create-pull-request#2867</a></li>
</ul>
<p><strong>Full Changelog</strong>: <a
href="https://github.com/peter-evans/create-pull-request/compare/v6.0.4...v6.0.5">https://github.com/peter-evans/create-pull-request/compare/v6.0.4...v6.0.5</a></p>
<h2>Create Pull Request v6.0.4</h2>
<p> Improves performance in some cases for very large git
repositories.</p>
<h2>What's Changed</h2>
<ul>
<li>perf: limit the fetch depth of pr branch by <a
href="https://github.com/peter-evans"><code>@​peter-evans</code></a> in
<a
href="https://redirect.github.com/peter-evans/create-pull-request/pull/2857">peter-evans/create-pull-request#2857</a></li>
</ul>
<p><strong>Full Changelog</strong>: <a
href="https://github.com/peter-evans/create-pull-request/compare/v6.0.3...v6.0.4">https://github.com/peter-evans/create-pull-request/compare/v6.0.3...v6.0.4</a></p>
<h2>Create Pull Request v6.0.3</h2>
<p> Improves performance of the <code>push-to-fork</code> feature.</p>
<h2>What's Changed</h2>
<ul>
<li>build(deps-dev): bump <code>@​types/node</code> from 18.19.23 to
18.19.25 by <a
href="https://github.com/dependabot"><code>@​dependabot</code></a> in <a
href="https://redirect.github.com/peter-evans/create-pull-request/pull/2826">peter-evans/create-pull-request#2826</a></li>
<li>build(deps-dev): bump <code>@​types/node</code> from 18.19.25 to
18.19.26 by <a
href="https://github.com/dependabot"><code>@​dependabot</code></a> in <a
href="https://redirect.github.com/peter-evans/create-pull-request/pull/2831">peter-evans/create-pull-request#2831</a></li>
<li>build(deps-dev): bump <code>@​types/node</code> from 18.19.26 to
18.19.28 by <a
href="https://github.com/dependabot"><code>@​dependabot</code></a> in <a
href="https://redirect.github.com/peter-evans/create-pull-request/pull/2836">peter-evans/create-pull-request#2836</a></li>
<li>build(deps-dev): bump <code>@​types/node</code> from 18.19.28 to
18.19.31 by <a
href="https://github.com/dependabot"><code>@​dependabot</code></a> in <a
href="https://redirect.github.com/peter-evans/create-pull-request/pull/2842">peter-evans/create-pull-request#2842</a></li>
<li>fix: drop unnecessary fetch with unshallow on push-to-fork by <a
href="https://github.com/peter-evans"><code>@​peter-evans</code></a> in
<a
href="https://redirect.github.com/peter-evans/create-pull-request/pull/2849">peter-evans/create-pull-request#2849</a></li>
</ul>
<p><strong>Full Changelog</strong>: <a
href="https://github.com/peter-evans/create-pull-request/compare/v6.0.2...v6.0.3">https://github.com/peter-evans/create-pull-request/compare/v6.0.2...v6.0.3</a></p>
</blockquote>
</details>
<details>
<summary>Commits</summary>
<ul>
<li><a
href="6d6857d369"><code>6d6857d</code></a>
fix: update proxy support to follow octokit change to fetch api (<a
href="https://redirect.github.com/peter-evans/create-pull-request/issues/2867">#2867</a>)</li>
<li><a
href="9153d834b6"><code>9153d83</code></a>
perf: limit the fetch depth of pr branch (<a
href="https://redirect.github.com/peter-evans/create-pull-request/issues/2857">#2857</a>)</li>
<li><a
href="c55203cfde"><code>c55203c</code></a>
fix: drop unnecessary fetch with unshallow on push-to-fork (<a
href="https://redirect.github.com/peter-evans/create-pull-request/issues/2849">#2849</a>)</li>
<li><a
href="6ce4eca6b6"><code>6ce4eca</code></a>
build(deps-dev): bump <code>@​types/node</code> from 18.19.28 to
18.19.31 (<a
href="https://redirect.github.com/peter-evans/create-pull-request/issues/2842">#2842</a>)</li>
<li><a
href="36ef0ed92f"><code>36ef0ed</code></a>
build(deps-dev): bump <code>@​types/node</code> from 18.19.26 to
18.19.28 (<a
href="https://redirect.github.com/peter-evans/create-pull-request/issues/2836">#2836</a>)</li>
<li><a
href="8500972a13"><code>8500972</code></a>
build(deps-dev): bump <code>@​types/node</code> from 18.19.25 to
18.19.26 (<a
href="https://redirect.github.com/peter-evans/create-pull-request/issues/2831">#2831</a>)</li>
<li><a
href="bda5ade93c"><code>bda5ade</code></a>
build(deps-dev): bump <code>@​types/node</code> from 18.19.23 to
18.19.25 (<a
href="https://redirect.github.com/peter-evans/create-pull-request/issues/2826">#2826</a>)</li>
<li>See full diff in <a
href="https://github.com/peter-evans/create-pull-request/compare/v6.0.2...v6.0.5">compare
view</a></li>
</ul>
</details>
<br />


[![Dependabot compatibility
score](https://dependabot-badges.githubapp.com/badges/compatibility_score?dependency-name=peter-evans/create-pull-request&package-manager=github_actions&previous-version=6.0.2&new-version=6.0.5)](https://docs.github.com/en/github/managing-security-vulnerabilities/about-dependabot-security-updates#about-compatibility-scores)

You can trigger a rebase of this PR by commenting `@dependabot rebase`.

[//]: # (dependabot-automerge-start)
[//]: # (dependabot-automerge-end)

---

<details>
<summary>Dependabot commands and options</summary>
<br />

You can trigger Dependabot actions by commenting on this PR:
- `@dependabot rebase` will rebase this PR
- `@dependabot recreate` will recreate this PR, overwriting any edits
that have been made to it
- `@dependabot merge` will merge this PR after your CI passes on it
- `@dependabot squash and merge` will squash and merge this PR after
your CI passes on it
- `@dependabot cancel merge` will cancel a previously requested merge
and block automerging
- `@dependabot reopen` will reopen this PR if it is closed
- `@dependabot close` will close this PR and stop Dependabot recreating
it. You can achieve the same result by closing it manually
- `@dependabot show <dependency name> ignore conditions` will show all
of the ignore conditions of the specified dependency
- `@dependabot ignore this major version` will close this PR and stop
Dependabot creating any more for this major version (unless you reopen
the PR or upgrade to it yourself)
- `@dependabot ignore this minor version` will close this PR and stop
Dependabot creating any more for this minor version (unless you reopen
the PR or upgrade to it yourself)
- `@dependabot ignore this dependency` will close this PR and stop
Dependabot creating any more for this dependency (unless you reopen the
PR or upgrade to it yourself)


</details>

> **Note**
> Automatic rebases have been disabled on this pull request as it has
been open for over 30 days.
2024-06-13 17:58:22 +03:00
.github build(deps): bump peter-evans/create-pull-request from 6.0.2 to 6.0.5 (#889) 2024-06-13 17:58:22 +03:00
build-aux/flatpak feat: Bump to 0.8.0-beta2, update dependencies and tweak UI 2024-01-04 03:41:44 +03:00
data appdata: translate=no properties 2024-03-31 02:25:07 +03:00
gradience fix: Typo 2024-04-12 17:37:28 +03:00
po translate: translated using Weblate (Italian) 2024-06-10 15:09:24 +02:00
.editorconfig misc add more rules to .editorconfig 2023-03-12 19:53:27 +00:00
.gitignore meta: add builddir;export to .gitignore 2023-04-30 20:09:26 +00:00
.gitmodules feat: move plugins to submodules 2023-08-15 21:10:36 +02:00
.pylintrc meta: update and rename pylintrc 2022-12-27 21:13:20 +01:00
CHANGELOG.md doc: Fix typo 2023-05-04 22:04:00 +03:00
CODE_OF_CONDUCT.md feat: add link to gnome coc 2022-11-21 19:25:29 +01:00
gradience.doap chore: Update roadmap, fix doap gradience website 2023-06-27 15:43:47 +03:00
HACKING.md feat: Bump to 0.8.0-beta2, update dependencies and tweak UI 2024-01-04 03:41:44 +03:00
LICENSE Create LICENSE 2022-08-10 23:51:10 +02:00
local.sh scripts: fix if statement in local.sh 2023-03-06 00:39:37 +01:00
local_cli.sh meson: configure local build launchers if buildtype is set to debug 2023-02-11 22:06:05 +01:00
MAINTAINERS.md fix: nicknames and links 2022-09-16 15:34:28 +03:00
Makefile meson: remove depracation warnings in newer Meson versions 2022-11-11 01:42:00 +01:00
meson.build feat: Bump to 0.8.0-beta2, update dependencies and tweak UI 2024-01-04 03:41:44 +03:00
README.md Update README.md 2024-04-20 16:18:39 +03:00
requirements.txt GNOME Shell theming support (#679) 2023-05-04 13:24:18 +00:00
ROADMAP.md doc: update roadmap 2023-06-28 09:43:15 +02:00
SECURITY.md chore: Update sec. policy versions 2023-06-27 15:38:58 +03:00
typos.toml misc: CI improvements (#700) 2023-01-18 03:04:00 +03:00

Important

Gradience is looking for a maintainer(s)! if you know Python and GTK4/Libadwaita and willing to work on it, chip in on Matrix and Discord.

Gradience
Gradience

Change the look of Adwaita, with ease

Download on Flathub


Translation status Build status Flathub downloads Packaging status

Chat on Matrix Chat on Discord

Please do not theme this app

Preview

Gradience is a tool for customizing Libadwaita applications and the adw-gtk3 theme.

Important

Gradience, stopthemingmy.app and Adwaita Developers

The main features of Gradience include the following:

  • 🎨 Changing any color of Adwaita theme
  • 🖼️ Applying Material 3 color scheme from wallpaper
  • 🎁 Usage of other users presets
  • ⚙️ Changing advanced options with CSS
  • 🧩 Extending functionality using plugins
📷 More screenshots

Monet Tab

Proof of Work

🎨 Theming setup

Note

You can go to Preferences and apply overrides for Flatpak

🪛 Manual setup

Libadwaita applications

No additional setup is required for native Libadwaita applications.

For Flatpak Libadwaita applications, you need to override their permissions:

  • Run sudo flatpak override --filesystem=xdg-config/gtk-4.0 or
  • Use Flatseal and adding xdg-config/gtk-4.0 to Other files in the Filesystem section of All Applications

Vanilla GTK 4 applications

Use this guide to theme vanilla GTK 4 applications.

GTK 3 applications

  • Install and apply the adw-gtk3 theme (don't forget to install the Flatpak package!)
  • For Flatpak applications, you need to override their permissions:
    • Run sudo flatpak override --filesystem=xdg-config/gtk-3.0 or
    • Use Flatseal and adding xdg-config/gtk-3.0 to Other files in the Filesystem section of All Applications

🔄 Revert Theming

  1. Open Preferences window

Main Gradience Menu

  1. Go to Theming tab

  2. In Reset & Restore Presets group, click Reset button for either GTK 3 or Libadwaita applications

Reset & Restore Presets Group

🪛 Manual revert

Remove GTK 3 and GTK 4 configs

  • Run rm -rf .config/gtk-4.0 .config/gtk-3.0

Remove adw-gtk3 theme

  • Run flatpak uninstall adw-gtk3 to remove Flatpak adw-gtk3 theme
  • Run rm -rf .themes/adw-gtk3 .themes/adw-gtk3-dark .local/share/themes/adw-gtk3 .local/share/themes/adw-gtk3-dark to remove local adw-gtk3 theme

Reset Flatpak overrides

  • Run sudo flatpak override --reset

Warning

This will reset all Flatpak overrides, such as Firefox Wayland override

📦 Alternative installation methods

Important

The main installation method is Flatpak from Flathub

Note

There are number of Gradience packages that are not tested by Gradience Team and not listed here, available at Repology

Fedora (COPR)

Gradience is available for Fedora via COPR:

dnf copr enable lyessaadi/gradience
dnf install gradience

Debian (And derivatives)

Warning

Not available yet.

Arch Linux (AUR)

Gradience is available for Arch Linux via AUR:

Using Paru:

paru -S gradience

For latest changes:

paru -S gradience-git
🪛 Without AUR helpers
git clone https://aur.archlinux.org/gradience.git
cd gradience
makepkg -sic

For latest changes:

git clone https://aur.archlinux.org/gradience-git.git
cd gradience-git
makepkg -sic

NixOS

Gradience is available for NixOS 23.05 (Stoat) and later:

To run in a temporary shell:

nix-shell -p gradience

To install:

nix-env -iA nixos.gradience

🏗️ Building from source

Nightly Build

First of all, you need to have GNOME Nightly Flatpak remote added if it's not already:

flatpak remote-add --if-not-exists gnome-nightly https://nightly.gnome.org/gnome-nightly.flatpakrepo

Then, download the Gradience nightly from here

Finally, extract the ZIP and install Gradience by running:

flatpak install gradience-devel.flatpak

GNOME Builder

GNOME Builder is the environment used for developing this application. It can use Flatpak manifests to create a consistent building and running environment cross-distro. Thus, it is highly recommended you use it.

  1. Download GNOME Builder.
  2. In Builder, click the "Clone Repository" button at the bottom, using https://github.com/GradienceTeam/Gradience.git as the URL.
  3. Click the build button at the top once the project is loaded.

For more building and installation methods, see HACKING.md

🎛️ Miscellaneous

Show welcome window again

The following command will make Gradience show welcome screen on next launch, like you just installed it

Flatpak

flatpak run --command=gsettings com.github.GradienceTeam.Gradience reset com.github.GradienceTeam.Gradience first-run

Alternative installation methods

gsettings reset com.github.GradienceTeam.Gradience first-run

FAQ

How can I launch a CLI?

Refer to temporary CLI documentation in repo's wiki for instructions on how to launch a CLI.

🙌 Contribute to Gradience

See HACKING.md

Contributors

Contributors

🏷️ About the Name

Gradience was originally named Adwaita Manager.

You can see the meaning of Gradience on Wiktionary.

The icon represents: A Paint Roller repainting an Adwaita window, keeping its functionality.

🖌️ About the "Pretty Purple"

The Pretty Purple theme comes from the very beginning, directly from the original author of Gradience, Artyom Fomin.

It was called "Purple Guy", presumably as a reference to the FNaF, later it was renamed to Pretty Purple.

Pretty Purple preset was originally shared in the https://github.com/GradienceTeam/Gradience/discussions/23.

Pretty Purple is built-in in the Gradience and used in all Gradience artworks.

🌱 Gradience, stopthemingmy.app and Adwaita Developers

See gradienceteam.github.io/hack

Gradience Team is not against the ideas of stopthemingmy.app and the developers of Adwaita. Gradience is a tool for tinkerers who want to theme their desktop to their liking, and not a tool for distributions to ship in their releases. Gradience Team agrees with importance of unified look of Adwaita to make sure that all apps function correctly and that developers have a unified and stable tool for creating their apps.

💝 Acknowledgment

Special thanks to:

  • Original author of Gradience, Artyom Fomin for creating this project
  • Weblate for providing translation platform

This README is based on README from Kooha by Dave Patrick Caberto

🪞 Mirrors